loader

Korrektur "Visual Studio 2005 SP1 erfordert ein Update für Windows Vista"

Anonim

Ich hatte gehört, dass Visual Studio 2005 Kompatibilitätsprobleme mit Windows Vista hat, daher war ich nicht überrascht, als ich diese Fehlermeldung erhielt, als ich zum ersten Mal versuchte, sie auszuführen. Um diese bestimmte Fehlermeldung zu beheben, müssen Sie das SP1-Update installieren, das so ziemlich das Service Pack für das Service Pack ist, denke ich.

Sie können das SP1-Update hier herunterladen: //go.microsoft.com/?linkid=6366078

Nach der Installation dieses Updates wurde die folgende Fehlermeldung angezeigt: "Administratorberechtigungen werden zum Ausführen von Visual Studio 2005 SP1 empfohlen". Sie werden aufgefordert, beim Starten von Visual Studio die Option Als Administrator ausführen zu verwenden.

Nach einigen Recherchen haben Sie mehrere Möglichkeiten:

  • Führen Sie Visual Studio als Administrator aus (am besten ändern Sie einfach die Verknüpfung, um immer als Administrator ausgeführt zu werden.) Auf diese Weise werden immer noch einige Fehler angezeigt.
  • Führen Sie Visual Studio als normaler Benutzer aus und öffnen Sie es nur als Administrator, wenn Sie einen bestimmten Fehler erhalten, der Administratorzugriff erfordert.
  • Deaktivieren Sie einfach das Kästchen.

Tipp: Wenn Sie versuchen, Webprojekte zu debuggen, müssen Sie sicherstellen, dass Sie in der Systemsteuerung Windows-Komponenten hinzufügen / entfernen auswählen und die Option IIS6-Kompatibilität mit IIS7 installieren. Andernfalls haben Sie nicht viel Glück.

Insgesamt ist Visual Studio 2005 mit Vista nicht sehr kompatibel. Es ist frustrierend, aber das ist das Leben.

Tipp Der Redaktion